Hey, I got a new Ubuntu 16.10 Yakkety install, and downloaded Ygopro 1.033.A.

I followed all the steps in this  link like I did on Ubuntu 16.04 LTS, but this time I couldn't install libsfml-audio2.3v5.

In 16.10 Yakkety, It has a new version, libsfml-audio2.4. I tried installing that from Synaptic then running Ygo but it wouldn't open.

I ran ldd ygopro as was suggested and it asserts I need to have libsfml-audio2.3v5 specifically. I've never downloaded an older library version before, and not so sure if I want to, so just letting you guys know that it seems to be oudated, in case there's a fix, or at least for the next version

Edit: forgot to say libsfml-audio2.3v5 isn't available at all in package manager on Yakkety so I'd have to pull it from online.
I got a quick fix from fjortisar over at reddit in case anybody else needs it.

You can either:

1) Make a symlink of the sfml-audio and sfml-system 2.4 libraries and run the game. I don't think I did that properly so idk if it works.

2) Download the packages from official Ubuntu site here  (substitute system for audio, or just search it up to also get the sfml-system 2.3 library), and extract the .so files to /usr/lib (I think /lib would work too, just saying what I did) then run sudo ldconfig. After that double-clicking on ygopro brings it up :)

Edit: code to make the symlinks, though it didn't work for me but I think I had gotten the package name wrong.


ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/
ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/
ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/libsfml-system2.3v5

Should work, based on the file names of the packages I downloaded