so I have already try this ygopro at different internet cafes and it works just fine but now I am trying to use it at home I cannot log in. I already try re-update and re-installing but it is still says connecting as if there is really happening and I don't think the internet is the problem. Please help me [:wall:] [:wall:] [:wall:]
I also can't seem to login. I register an account, it updates everything but it keeps getting stuck at connecting after I click login.
Same here. I'm stuck at connecting when trying to login. It has been like this for a couple days now. Would really appreciate a moderator's support on this issue. I have tried loading the application as administrator as well as trying to close it and reopen it to try and start the program, I also tried to manually fetch updates and reinstall completely to no avail. Thanks. 
Hi guys,

This is the forum for Ygopro Percy, which doesn't require a login.

What you are using is probably Tdoane. For help with that visit their forum. Of course, you are more than welcome to use our version instead. Thank you.
Users browsing this topic