Arthurkirkland
2017-05-14T20:26:43Z
Right now i created an Lua for 2 cards,But the problem is that their effect doesn't work at all when i add them on YGOPRO and test them.


*Insert line* <eof> expected near 'end'
CallCardFunction (c*Insert card id* initial effect) attempt to call an error function


This error pops up with both 2 cards,Also i'm not sure that even if i fix this,The 2 cards will work with the intended effects:


Effect of card 1 (c46583731) : Once per turn,If this card battles an opponent's monster, during damage calculation:Target the battling monster; Its ATK becomes 0, and if it does; this card gains that lost ATK until end phase



Effect of card 2 (c31122092) : During either player's turn, You can discard this card then target 1 monster you control; It cannot be destroyed by battle or card effects this turn. You can banish this card from your graveyard, then target 1 monster in your graveyard; add it to your hand. You can only use this effect once per turn.
File Attachment(s):
c31122092.lua (3kb) downloaded 6 time(s).
c46583731.lua (2kb) downloaded 2 time(s).

You cannot view/download attachments. Try to login or register.
Hippocampus1901
2017-05-16T03:13:45Z
Hi Arthurkirkland,

Yeah I noticed a lot of errors with your card scripts. I tried making them for you, but I haven't tested them yet. Here is card 1:
And here is card 2:
See if these work!
Arthurkirkland
2017-05-16T18:22:11Z
Originally Posted by: Hippocampus1901 

Hi Arthurkirkland,

Yeah I noticed a lot of errors with your card scripts. I tried making them for you, but I haven't tested them yet. Here is card 1:

And here is card 2:
See if these work!




Everything is good except Card 1's effect doesn't last until end phase.
SotheY
2017-05-16T18:43:16Z
Change e2:SetReset(RESET_EVENT+0x1fe0000) to e2:SetReset(RESET_EVENT+0x1fe0000+RESET_PHASE+PHASE_END)