SlowHand
2013-11-17T21:22:34Z
So I have a gravekeepers and bujin deck and added the new cards from Legacy of the Valiant and every time I try to

duel it says invalid deck. Has anyone else been having the problem?
Steeldarkeagel
2013-11-17T21:25:11Z
The Linux server has not been updated for all the new cards.

Please wait for Checkmate to update it, for the moment use the Usa/Eu servers for the new cards.

Edit:
It has now been updated.