App doesn't turn sideways 

Got it to turn sideways but is then unusable 
I clicked the ad then back buttoned into ygopro again.
Searched around to see if there are any known orientation related problems on the LG L86C, but I can't find anything useful.

Can you download the updated version from Google Play? I modified some landscape mode settings. If you still get the same problem then try turning your device 180 degrees.
I don't know of any other apps having an orientation issue. I tried every way of rotating the phone.

I'm downloading the update now on mobile. At about 7kbps so I'll have an update for you in a couple of hours
After updating the app it started with the same orientation issue at the loading screen. The main menu also loaded withthe same problem.

After clicking the ad and using the back button on my phone to reenter the app it was orientated correctly.

Everything on the menu then worked and I started an online multiplayer match.

The app runs slowly on my phone but runs perfectly.

It then randomly went black screen on me as shown in the screen cap. I don't know what triggered it to happen but the app was frozen on the black screen. 
I don't think you need to click on the ads to exit and reenter. Just press the home key and start ygopro again. The game should still be running.

Can you play against the AI without getting a black screen?
It does work if you use the home button and reenter the app. It takes 4+ tries but it does work.

It froze on AI mode when asking if I wanted to chain to an effect. This is the screen it froze on. 
When I rotate the phone while playing it goes to black screen and I have to force close the game to reset it.

This may have been the cause the other times. The gyro in my phone is rather sensitive so the mildest tilt of the phone can cause the screen to rotate.

I've been able to duplicate this result every time I rotate the phone while in the app.

Also, multi touch to cancel works perfectly in AI and online multiplayer but not at all in puzzle. I don't know if it is supposed to our not.

Hope this helps